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In troduction 

The Internet has progressed at amazlIlg speed in recent years. Once the 

realm of academics and defense agencies, Internet is rapidly becoming a 

mainstream media conduit for communication between individuals, 

companies, and global dwellers. 

AS part of the Internet, World Wide Web is now the predominant force in 

growth. Its language is simple, its interface is attractive and friendly , and it 

is adaptable to a wide variety of uses. 

There are now Web sites for selling products, selling ideas, maintaining 

appearances, informing public, continuing education and knowledge, and 

just plain wasting time. And in a growing trend, the Internet concept is being 

adapted to inte rnational cOl1llllunication by establishing Intranets inside 

compames. 

Normally, man has to roam about here and there to get information to make 

investigation and to collect data but nowadays, it is preferable to sit in your 

home, just browse the web and get information . 

The Web Site designed by me copes with all the challenges and it IS 

designed in such a way that it fulfills the modern requirements of the age. 



The data available about Multan was scarce. No attractive brochures Or 

anything of the sort is available from any agency or source of information. 

Rather a person who is keen to know about Multan and its interesting places 

has to go through a survey of various departments. In this way sooner or 

later either one gets frustrated or encounter shortage of time to see all around 

this city. 

Keeping in VIew all the reasons the need anses for a complete and 

comprehensive source of information about Multan. A source which is self 

sufficient to cater for the information services, easily accessible to all those 

who are enthusiastic to visit Multan. This was possible more efficient way to 

have a web site ofMultan. 

This Web Site of Multan provides a reliable and satisfactory approach to get 

information about M ultan. The browsers , all over the world , can utilize 

this source of information with effortless ease. 

This site of Multan will provide facilities to tourists to plan their visit before 

coming to the place. This site will also help the people of Pakistan to know 

more about Multan. Different topics, which are included in this web site, 

will certainly fulfill the knowledge requirements of all the people. 
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Project Overview 

MULTAN (Introduction) 

"With four rare things Multan abounds 

Heat, beggars, dust and burial grounds" 

The above couplet by a Persian poet describes the primordial environment of 

the historic city ofMultan. But that has changed now and not only the city of 

Multan but the district itself has been transformed into a green, fertile area. It 

is fast becoming an industrial town. The city has its own charm, culture and 

crafts. The origin of the name 'Multan' is obscure and so is the period of its 

founding. It has been called as Mulosan pulu by Hiuen Tsang and Alberuni 

called it Multana which ultimately came to be called Multan. 

BRIEF HISTORY 

The history of Multan prior to the arrival of the Arabs in the 8th century 

A.D. is obscure. Alexander is said to have passed through the district in 

about 325-326 B.C., but his route cannot be traced. It is probable that Multan 

was the city ofMalli which Alexander stormed and where he was wounded. 

About 327 B.C. the Macedonians were ousted by 

Chandragupta and the Maurya dynasty remained in power till the beginning 

of the second century A.D. From 30 B.C. to 470 A.D., the Kushan dynasty 

ruled over the area, and from 470 to 550 A.D. , the White Huns are believed 
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to have held sway. Multan figures as the capital of an important province of 

the Kingdom of Sindh in the writings of the early Arab geographers. At the 

time the Arabs first came to Sind, the country was ruled by Raja Chach, a 

Brahmin. Multan was conquered by Arabs under Mohammad Bin Qasim in 

712 A.D. after defeating Raja Dahir, a descendant ofChach. Thereafter, the 

town remained for three centuries the outpost of Islam in India, under the 

caliph of Baghdad. It remained nominally subject to the Lodhies, 

Ghaznavids and Mohammad Ghauri up to the end of 12 century. From the 

beginning of the 13 century for the next three centuries, the history of 

Multan is practically the history of the incursions from Western and Central 

Asia. 

In 1397 came the invasion by Taimur, whose troops occupied Uch and 

Multan, sacked Tulamba, raided the Kohkhars of Ravi and passed across 

Biass to Pakpattan and Delhi. In 1528, came the peaceful transfer of the 

province of Multan to the emissaries of the Mughal Emperor Babar. Under 

the Mughal Emperors, Multan enjoyed a long period of peace between 1528-

1748 and was known as Dar-ul-Aman (city of peace). In 1752 Multan 

became a province owing allegiance to Afghan kings. It was then ruled by 

Pathan Governors and Daud Putra Chiefs of Bahawalpur for some time. 

After 1771, Multan witnessed continued warfare between Sikhs and the 

Nawabs ofMultan. Between 1818 and 1845, it remained under the Sikh rule 

and finally came under the British rule in 1849. 

Mullan City 

Multan city has the distinction of being the birthplace of three distinguished 

men in history: Mohammad Tughlaq is said to have been born in 13 century 

in a hamlet at the place which is now known as 'Kotia Toleh K-han'. 
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Emperor Bahlol Lodhi was born in Qazian wala Makan near Hussain Agahi. 

Ahmed Shah Abdali, the first Durrani sovereign of Afghanistan, was also 

born at Multan in 1722. 

The city of Multan is bound on the north by the depression lying between it 

and the fort and on all other sides by a brick wall. It has six gates i.e., 

Lohari Gate, Pak Gate, Bohar Gate, Delhi Gate, Haram gate and Daulat 

Gate. 

The old city has narrow colourful bazaars full of local handicrafts and 

narrow winding lanes. There are many places of historical, cultural and 

recreational interest in the city. 

THE FORT 

Multan Fort was built on a mound separating it from the city by the old bed 

of river Ravi. Its date cannot be fixed with accuracy. When intact, its 

circumference was 6,600 ft. having 46 bastions, including two towers at 

each of the four gates i.e., Delhi Gate, Khizri Gate, Sikhi Gate and Rehri 

Gate. The fort was ravaged by the British to avenge the murder of one Mr. 

Agnew in 1848. At present it is survived by some parts of the old rampart 

and bastions besides the shrines of Hazrat Bahauddin Zakaria and Shah 

Rukn-e-Alam, an obelisk in memory of Agnew and a Hindu temple. The 

famous Qasim Bagh and a stadium are located within the walls of the fort. A 

panoramic view of Multan city can be had from the highest point in the fort. 

SHRINES 

ous 
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and learned men and noble famili es like Gardezi Syeds and Qureshis from 

Khwarizm, amongst whom Sheikh Bahauddin Zakaria is a famous saint. 

About the same time Pir Shams Sabzawari from Sabzwar and Kazi 

Qutubuddin from Kashan came to M ultan. Baba Farid Shakar Ganj was born 

in a village of Multan, and settled in Pakpattan. Khawaja Qutubuddin 

Bakhtiar Kaki passed through Multan to Delhi and Syed Jalal, the spirtual 

leader of many families in Multan, Muzaffargarh and Bahawalpur came to 

Dch. Sultan Sakhi Sarwar's father also emigrated from Bukhara to Sarwar 

Shah Kot in Multan district. These venerable men contributed greatly to 

spreading Islam in this area. The saints and shrines of Multan have been 

attracting a large number of devotees all the year round. 

One of the foremost scholars of Islam, Shaikh Baha-ud-din Zakria's shrine is 

located in the fort. He was born in 1170 A.D. , Studied in Turan and Iran and 

received instructions from Shaikh Shahab-ud-Din Suharwardi at Baghdad. 

His Mausoleum was built by the saint himself. It has a unique style of archi­

tecture of that period, the only other being at Sonepat in India. It also houses 

the graves of most of the eminent members of the Qureshi family, including 

that ofNawab Muzaffar Khan. 

The Mausoleum of Shah Rukn-c-Alam, the grandson of 

Shaikh Bahauddin Zakaria, is also located near the main gate of the Multan 

fort. He was also a man of great religious and political influence during the 

Tughlaq reign and was in Multan when it was visited by Ibn-e-Batuta. The 

Mausoleum was originally built by Emperor Ghayasud Din Tughlaq but was 

given up by his son Muhammad Tughlaq in favour of Shah Rukn-e-Alam. 

Beside its religious importance, the Mausoleum has a unique architectural 

value. Its dome is considered to be the second largest in the world. The 
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Mausoleum has recently been given the Agha Khan award for the best 

Muslim architecture. Some of the interesting Statistic so fits architecture are: 

(a) Total height above the road level is 150 ft 

(b) Total height of building is 100 ft 

© Octagonal upper structure diameter is 26 ft 

(d) Octagonal lower structure diameter is 52 ft 

(e) The dome on top has a diameter of 58ft 

The Mausoleum has very rich geometrical patterns, calligraphy and 

colourful floral, mosaic and glazed tile work. The shrine is visited by 

devotees all the year round. The shrine of Hazrat Shams Sabzwari is located 

near Aam-Khas Garden. A descendant of Imam Jaffar, he was born in 1165 

A.D. The saint died in 1276 A.D. and his shrine was built by his grandson in 

1330 A.D. 

Oth~r Shrines: 

Other Shrines in Multan include those of Mohammad Yousaf Gardezi near 

Bohar Gate, Musa Pak Shaheed inside the Pak Gate, Totia Mai near Haram 

Gate, Shah Ali Akbar, a descendant of Shah Shams Sabzwari, in Suraj Miani 

and Baba Safra near Eidgah. 

MOSQUES OF MULTAN 

The famous mosques of Multan are Wali Mohammad Mosque in Chowk 

Bazar built by Ali Muhammad Khakwani in 1758 A.D., Mosque Phulhatt in 

Chowk Bazar built by Emperor Farrukh Siyar, -Baqarabadi Mosque built by 

Baqar Khan in 1720 A.D. and the beautiful Eidgah Mosque built by Nawab 

Abdul Samad Khan in 1735 A.D. 
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OTHER PLACES 

Multan has some beautiful modem buildings such .as Nishtar Medical 

College, University Campus, Arts Council building with an auditorium, 

Multan Railway Station building: 

the famous Clock Tower building of the Multan Municipal Corporation and 

State Bank of Pakistan, etc. There are places of recreation in Multan such as 

the; 

Stadium, the Lake Chaman zar-e-Askari and Company Bagh in; the 

Cantonment, the Stadium and Qasim Bagh in the Multan Fort, Lange Khan 

Garden, Aam-Khas Garden and the parks at; 

Bohar gate, Chowk Shaheedan, Tabbi Sher Khan and the' Nawan Shaher in 

and around Multan. 

FESTIVALS, FAIRS AND MELAS 

Religious festivals in Multan are a peculiar mixture of devotion and 

recreation. Multan is famous for its shrines. Annual urs is held on every 

shrine. Well known are the urs of Shah Rukn-e-Alam, Bahauddin Zakaria, 

Shah Shams Sabzwari, Shah Jamal, Sher Shah and Mela Ludden Pir, etc. 

Meals 

Western and Pakistani dishes are available in Western style hotels. Lassi, 

Sharbat and Faluda are local cold drinks, Multani Halwa (Sweet Preparation) 

is also famous. Amongst fruits, mangoes, water-melons, kino, oranges, 

pomegranates, guavas and dates are grown in the district and are available 

during the season besides other fruits. 
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Local Handicrafts: 

Multan is famous for various types of souvenirs. Multan'i Khussa (shoes), 

embroidery work of all types, thread and 'Aar' work costumes for ladies, 

embroidered cloths cholas or kurtas "for men" painted and glazed earthen 

pottery. Camel skin products, carpets and lacquered wooden products etc. 

are available in the narrow colourful bazaars. 

Shopping Centers: 

Main shhoping centers are Bazaar Hussain Agahi, Chowk Bazaar, Bohar 

Gate, Haram Gate, Delhi Gate, Lohari Gate and Pak Gate Bazaars in the old 

city and the Cantonment shopping area. 

Costumes: 

The men in rural areas wear a 'Pag' or ' Patka' (turban) or sometimes a 

'Kulla' White or blue waist cloth or 'Majhia', a 'Chola' or long shirt and a 

'Chadar' worn over the shoulders. Amongst educated class in urban areas, 

Shalwar - Qameez and the western dress is common. Women wear Shalwar, 

'Lehnga' or 'Ghagra' , 'Chola' and 'Kurta' of bright colours. Short sleeved 

'Choli'or 'Kurti'is also worn in the rural areas. The head is covered with 

'Bochan' or dupatta or embroidered and Phulkari chadars. 
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GENERAL INFORMATION 

Location: 

Longitude: 

Area: 

Population: 

North Latitude 29'- 22' and 30'- 45' and East 

71-- 4' and 72-55 ' 

45 square km 

1,288,170 (1998 census) 

Languages: Urdu, Punjabi and Saraiki. English is spoken an understood by 

educated people. 

Climate: Cold in winter and very hot in summer. The normal rainfall is 

about 6" during the monsoon from July to September. 

Wildlife: Fox, Jackal and wild boar. Amongst birds are grey 

and black partridges, sand-grouse visit the district in winter, quail, 

plover and pigeons are common. 
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SOFTWARES USED 

It was decided to put all the collected information in the form of web pages, 

so that all can easy access it. To design web pages, the best choice that I can 

chose was to use HTML language and to give them an attractive, sober and 

scholarly look. The software's selected were latest available and comprises 

of Text Editors, Graphics Manipulators, Image Processors and HTML 

Development environment. 

3.1 Software's Utilized 

3.1.1 Languages 

• HTML - Hyper Text Markup Language 

3.1.2 Graphics Pacl<.ages 

• Adobe Photo Shop 

• Fireworks 

3.1.3 Word Processors Employed 

• Notepad 

• MS WORD 97 

3.1.4 HTML Editors Used 

• Flash 
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• FrontPage 

• Microsoft Word 97 

3.1.5 B.·owsers Used 

• I nternel Explorer 

• Netscape Communi ca tor 

3.1.6 Operating Systems Employed 

• Windows 98 

3.2 Hardware Environment 

To get Optimum performance (l'om the software, the system should be IBM 

compatible Pentium II or higher , RAM 32 MB or more . 
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INTERNET· 

4.1 What is the Internet? 

The Internet is an open worldwide communications network, linking 

countless thousands of compule r networks, through a mixture of private and 

public te lephone lines. Government Agencies, Universities, Commercial 

and Voluntary Organizati ons indi vidually run its component networks. No 

single organization can own or control s the Internet society and sets 

s tandards for its use. 

4.2 Background History of Internet 

The Internet grew out of a long-distance network deve loped by the US 

G ove rnme nt' s Advanced Research Proj ects Agency (Arpanet) in the late 

1960s, The fast, high-vo lume te lephone links proved re li able and the 

network was extended over the next 10 years to connect 200 computers in 

military and research es tabli shments throughout the US and overseas. It 

demonstrated clearly that Internetwo rking (Interlinking networks) was both 

practical and hi ghly use iul. 

Some US uni versities fo llowed by setting up systems of the ir own. In the 

mid 1980s these Joined w ith the research part of Arpanet to form the 

I nternet. T he important thing to note here is that the Internet was not set up 

as a co mmercial ve nture. T here arc till Appropriate Use rules that restricts 

the Internet lor pro lit. 
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Today, most of the world's Universities are linked directly or indirectly; 

many businesses have joined, some toe take advantage of the cheap and 

efficient international communications, some to advertise their wares, or 

provide services, and others . to gain access to the mass of on-line data' a 

significant and growing number of political parties, pressure groups and 

charities are using it to network their members and get their messages across 

the World, 

These organizations bring many millions of people to the Internet, but there 

are also millions of individuals who link in their home computers through 

one or other of the many service providers, In the UK alone, there are over 

2,00,000 hosts computers on the Internet. As for individuals, CompuServe, 

the largest service provider, claims a UK membership of 100000 with 1000 

new users joining each month. 

At that time of writing, in 2001 there over 151. 5 million users of Internet in 

World their detail is as following: 

4.2.1 Net Connections 

World Total 151.5 million 

Africa 0.92 million 

Asia/Pacific 26 million 

Europe 32-38 million 

Middle East 0.78 million 

Canada & USA 87 million 

South America 4.5 million 

Expect a fourfold increase of online population by 2005. There are about 1.5 

million web sites, consisting of over 320 million pages. The net will eclipse 

newspapers as primary source of news by 2002. Amazon.com is the top 
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shopping site one in three Europeans homes online by 2003 about a million 

Russians are online 7 million online in UK - growth higher than France or 

German. 

40% of UK net users log in at home one in five UK people used net in 

2001 one in three UK children have used the net. 

43% of British schools online 

26% of adult Canadians online (6.3 million access it on a weekly basis) 

39% of Canadians have used the net - up from 275 a year earlier 

23% of Americans homes online by end of 1998 

12% of Americans accessed the Stars Report 

18% of Australian households online 

1.2 million Chinese now online 

9.4 million Chinese will be online by 2002 

12.1 million online in Japan 

4.3 Newsgroups 

These are a development of mail lists, and can be accessed by an e-mail 

connection, There are thousands of newsgroups, covering by amazing range of 

interests, activities and obsessions. Some newsgroups are very active, with 

hundreds of new articles every day; others have much lighter traffic. 

Some groups clearly have members with too much free time and free access to 

the Internet; in others, the articles are typically brief but relevant and 

interesting. Some groups are moderated that is they have someone to edit 

submissions and filter out the irrelevant ones. 
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4.4 File Transfer 

Throughout the Internet, there is a standard way of accessing directories on 

remote computer, and transferring files to and from them. This is FTP File 

Transfer Protocol. It consists of a set of user commands and underlying 

routines to manage the safe transmission of files. We can do FTP by logging 

in to a remote computer and giving the commands directly, but most users 

now manage FTP through a Windows interface such as WS FTP, which takes 

care of all the commands for him. It is also possible and sometimes more 

convenient to do FTP bye-mail, 

Sending a request detailing the file we want and where it is to an FTP server 

does it. This is a computer that runs a special program to deal with such 

requests. 

Sending a request detailing the file we want and where it is to an FTP server 

do it. This is a computer that runs a speoial program to deal with such 

requests. That raises the question of how we find where files are in the first 

place, and the solution there is Archie this is a program run on certain 

computers Archie servers that will search the Internets archives for us. It is 

worth nothing that most service providers keep a bank of commonly used 

programs, including most of the tools that we need for Internet work, on our 

own computers. 

This is always the first place to check for files, as obtaining them from mere 

is generally quicker and easier than searching for them elsewhere. 

A few years back at University of Minnesota, They came up with Gopher-a 

pun on 'Go for' and a reference to the University mascot designed to make it 

easier to find information of the Internet. 
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4.5 Gopher 

Gopher is not an Internet service in the sense that it is not built in the TCP/IP 

protocol, but developed to search data and information on the Internet by 

offering a text based menu interface. The name Gopher has an interesting 

history. 

It was developed at the University of Minnesota, who's mascot is Gopher. 

Some say that as the said software tunnels over/under the Internet looking for 

information, just as a mole like animal gopher digs tunnels, therefore, it 

should be called a Gopher, And last but not the least as Americana say, " Go 

for it", when said quickly, sounds much like gopher, try it. 

Using Gopher does not require a live Internet connection, and can be 

accessed using FDN. To avail this facility, use PAKNET, to connect to the 

server of ITU (International Telecommunication Union) by giving its DTE 

address 0228468111111 2 and login with user name Gopher. 

Gopher is a package of complementary programs that organize data and 

provide access to it. I f we are running a Gopher program and log in to a host 

Computer that acts as a gopher server, we will see a menu on our screen, 

Selection an item from This menu will either take to another menu of items or 

display a file. The file of menu that we see may be on the same host computer, 

or on another one somewhere else in the world. 

The great mass of information on these linked computers is sometimes 

referred to as Gopher space. The menus at usually well structured, with clear 

indications of what each item lead to. However, if we do not fancy tracking 

through the menus, there are two-search program. Veronica and J ughead. 

Most of the files that-can be accessed through Gophers are text, either plain or 
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formatted by a word processor, thought there are also a lot of graphics, plus 

some videos and sounds. 

To be able to see and hear these, we may already have some programs that 

can be used for viewing; others can be obtained from the data banks of the 

Internet. A good gopher program, such as Hgophe will have the ability to 

display files in a variety of formats, and to make links to other viewers. 

The points to note about the Gopher system is that: 

The emphasis is on academic material we can reach all of Gopher space 

through our Web browser, so dedicated Gopher software is not needed; there 

is relatively little new development in the Gopher system, as it has been 

largely overtaken by the world wide Web. 

4.6 The World Wide Web 

This is the newest and of many, the most exciting aspect of the Internet, It 

consists of several million pages of information stored on host computers 

throughout the world. The pages contain text, graphics, video clips, sounds 

and most importantly hyperlinks to other pages, which may be in the same 

computer or on another machine the other side of the world. To access the 

World Wide Web, we need an interactive connection with our service 

provider and a web browser a program that can interpret the links and 

display web pages- Like Gopher software, Web browsers can pass graphics, 

sounds and other formatted files to viewers for display. 
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4.6.1 What is the World Wide Web? 

Burners-Lee, in a 1995 talk, which we can find on the web at 

hHp:llwww.w3.Qrg' Ipub/www/ialks/CJeneral,hlinl. described the web as a " 

distributed heterogeneous collaborative multimedia information system." 

How does the web fit these criteria: Consider these points; 

The Web is distributed because information is available on computers all 

over the world. The Web is heterogeneous because its information is stored 

on a variety of computers and networking systems. 

The Web is collaborative because any .web user has the capacity to add 

information to this system. 

The Web is multimedia because it isn't limited to text; it can include 

graphics, sound, animation, and video. 

The home page of the World Wide Web Consortium (W3C) is a good place 

to get more information on the Web, 

4.6.2 History 0,( WWW 

World Wide Web was born at CERN (European Laboratory for Particle 

Physics) in 1989 as a way to send graphical files world wide, but its 

popularity skyrocketed in 1993 with the introduction of Mosaic, developed 

by National 

Center for Super Computing Applications at the University of Illinois. 

Currently there are more than 151 million Web users, more than 60000 
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commercial Web sites, thousands of educational and Government sites 

bringing the total to a staggering 100,000 WWW sites. 

Digicom in Sep/Oct, 1995, and since introduced graphical WWW in 

Pakistan then the popularity of WWW in Pakistan has skyrocketed and 

number of organizations have jumped in to capture the market. The ISPs 

offering WWW access have three areas of concentration, that is Karachi, 

Lahore and Rawalpindi/ Islamabad, Web access not graphics only, but can 

also be done using a text-based browser (lynx) offered by PTCL. 

Netscape and Internet Explorer are now largely superseding the first two 

Web Browsers Mosaic and Cello. The Web performs a very similar to 

gopher, in providing links between scattered information, but it does so in a 

more flexible and a more user friendly way. It has links through to gopher 

space, so that anything available there is available through a web browser. 

FTP file transfer and many newsgroups can also be accessed through the 

web. Finding information on the web is not difficult, There are several 

directories, which provide structured entries onto the mass of pages. The 

most popular of these at present is Yahoo we can also track down specific 

topics. 

4.6.3 Why People Make Web Pages Or Sites? 

People set up Web pages for many reasons as a public service, as an 

academic exercise or resource, as a public service, their products or for 

themselves, or simply as a mean of sharing their interests with others. As a 

result some Web pages are excellent sources of information in their own 

right, some are treasure troves of links to other valuable pages; and some are 

pure trivia. 
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4.6.4 Other Approaches 

For most people, e-mail, newsgroups. FTP, gopher and the World Wide Web 

provide as the access to the Internet that they need, and they are the ones that 

we will concentrate on. There are other approaches, however, that we may 

want to explore, as we become more experienced in using the Internet. 

Telnet allows us to log in to a remote computer and use as if our machine 

was directly attached to it, so we can search its directories and run programs. 

As most of these run the Unix operation system, we would be familiar with 

the essentials of Unix before attempting to telnet. W AIS, the Area 

Information Search tool, will trawl through indexed text files searching for 

those relating to defined topics. As the files arc largely academic papers and 

technical reports this is a tool that academics may find particularly valuable 

when starting to research a new topic. 

4.7 Internet Addresses 

Every computer site that is linked to the Internet has its own unique address. 

This is made up of two or more names, separated by dots, and they identify 

the country (if not based in the US), the nature of the organization, the 

organization itself and, may be, a particular computer or network. In the 

Jargon these are referred to as domains, 

Some of the major domains that we can see are: 

• fr France 

• fi Finland 

• ge Germany 

• uk United Kingdom Some typical examples are: 
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Microsoft. corn 

A commercial organization based in the US. 

vnet. ibm. com 

The unet network within the IBM Company-

Micros. hensa. ac. uk 

The computers on which the mIcro files are stored, at the University of 

Lanxaster (hensa), and academic site in the UK. 

Suns ite. unc. edu 

4.8 Un(form Resource Locators 

With all the millions of files, Gopher items and web pages that are 

accessible essential. URLs provide this. There are different styles of URLs 

for different approaches to the Internet, though they all follow the same 

pattern: 

Type:llhost_computer_address/directory_&filename 

4.9 Files For FTP 

These always specify the path from the top the directory containing the file. 

The filename is the last item of the list. 

ftp://ftp.temple.edu/publ1nfo funstuff/smilev.ixt 

This is the address of the file smiley. txt, which will tell us all we want to 

know and a lot that we don't about smiley and abbreviation that are used in 

e-mail. It is in the fun stuff directory, inside the info directory in the US Web 

pages. 

Many of these are instantly recognizable from their html ending, which 

shows that they are hypertext pages. 
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http;/sunsite.unc.edu/bouteilifaq/www-faq .htmi 

This one is a list of frequently asked questions (F AQ) and their answers, 

about the World Wide Web, stored in the sun archives that we noted above. 

(There are F AQ lists on many aspects of the Internet. Look for the F AQ 

whenever you start work in a new area it could save you a lot of head 

detaching). 

4.10 Gopher Items 

Gopher URLs are the most complicated of the lot, which reflect the fact that 

it is more complicated to point our gopher software at a Particular item, than 

it is to connect to a Web page or locate a file for ftp transfer. 

Gopher://gopher.ocf.berkelev.edu: 70/00/gopher/gopher- www 

The numbers after the site name identify the port that we have to connect to 

on the remote computer, and the nature of this should become clearer. 

4.11 Summary 

For many users, e-mail is the most useful Internet facility, as it enables them 

to keep in touch with friends throughout the world, at the cost of a brief 

phone call. 

• Newsgroups are a means by which people can share ideas and knowledge. 

There are thousands of newsgroups covering every conceivable interest. 

• As only text files are transferred bye-mail, and in news groups, these 

facilities require only the simplest of connections to the Internet and are 

offered by providers. 

» Ftp allows us to down load files from host computers, as long as we know 

their names and locations. 
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• Archie will find files for us. 

• Gopher software gives us access to a huge body of information organized 

through a hierarchy of menus. 

• The World Wide Web likewise gives access to masses of Information but 

organized in a more flexible way. 
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FLASH 

5.1 INTRODUCTION 

Flash 4 offers exciting new features for creating immerse, lush interactive 

web sites. New playback features include MP3 streaming audio, text fields 

for placing user-editable text in a movie, and enhancements to Flash actions 

that let you create sophisticated games, forms, and surveys. New authoring 

features include a streamlined publishing process, a redesigned Library 

window, a variety of new inspectors, and an enhanced graphical interface. 

5.2.1 Open the starting ,file 

• -In Flash, Choose File> Open, and 

then open the Tutorial Start.fla file. 

• -Choose File> Save As and save the 

movie with a new tile name so that you 

do not alter the Tutorial Start.fla file. 

• -If you, or another lIser, want to use 

the tutorial again, it's important to keep 

the original Tutorial Start.fla file. 

• -Tutorial Start should open with the 

Library window displayed. If the Library window isn't open, choose 

Window> Library to open it. 
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• -Tutorial Start has no content in the mam Timeline, but the Library 

window contains basic artwork you could have created with the skills you 

acquired doing the Flash lessons. 

5.2.2 Define the movie properties 

It's a good idea to start building a movie from the 

bottom up, so begin with its size and background. 

.-Choose Modify > Movie. 

MOVIIl PlullCl'ies ' , I:J 

• -In the Movie Properties dialog box, set the 

movie's dimensions to 550 pixels by 400 pixels. 

• -For Background, select an orange color. 

• -Click OK to apply the properties. 

• -The Stage is now orange. 

5.2.3 Create an animated symbol 
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The lesson , "Symbols," taught you how to work with graphic symbols and 

instances. Symbols can also include instances of other symbols and 

animation. In this section, you create a 

symbol that shows the photograph 

movmg to the refrigerator door at the 

beginning of the movie. 

You begin by creating a movie clip 

symbol and then adding other symbols to 

it. A movie clip symbo l is like a self- -
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contained movie that you can place in a host movie as if it were a single 

object. It can include animation and interactivity just like a regular movie. 

Note: While working in Flash, it's often useful to undo your actions. Flash 

can undo several of your recent actions. Choose Edit > Undo (or press 

Control+Z (Windows) or Command+Z (Macintosh)) repeatedly to step 

backwards through your recent actions. Choose Edit > Redo (or press 

Control+Y (Windows) or Command+Y (Macintosh)) to step forward 

through actions you've undone. 

5.2.4 Create a movie clip symbol 

• -Choose Insert> New Symbol. 

• -In the Symbol Properties dialog box, enter the name "INTRO -

ANIMATION." 

• -Select Movie Clip as the behavior and then click OK. 

• -Flash switches to symbol-editing mode. Symbol-editing mode looks 

almost exactly the same as movie-editing mode. Notice that the name of the 

symbol you're editing appears in the top left comer above the Timel.ine. The 

name also now appears in the Library 

window. 

~ Scene 1 m INTRO -ANIMATION 

a~c 
~~====9& =H~~ 

• -In the Timeline, double-click the existing layer name and enter "Photo. " 

• -Drag an instance of the INTRO - PHOTO symbol from the ~ 
~ 
~ 
~ 
~ 

Library window and place it over the registration point in the 

center of the Stage as shown in the picture that follows. 
~ 
~"«om:-.............,~'\,.,,,,,,,, .. ....s 
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• -This adds an instance of the INTRO - PHOTO symbol to the INTRO -

ANIMATION symbol. 

• -Use the arrow keys to move a 

symbol one pixel at a time. Press 

~ Scene 1 Illi]INTRO -ANIMATION 

Shift and use the arrow keys to move ten pixels at a time. 

• -In the Timeline, select frame 20 in the Photo layer and choose Insert > 

Keyframe. 

• -Because you want the animation to begin off the Stage, you must define a 

new position for INTRO -

PHOTO in the first frame. 

• -Select the keyframe In 

frame 1. 

• -Move the instance of 

INTRO - PHOTO about two inches to the right of the registration point. 

• -The exact location is not important. 

• -Now that you've positioned the image for the first fi·ame, you can create a 

motion tween to make it move to the position of the keyframe in frame 20. 

• -Making sure the keyframe in 

frame 1 is still selected, choose 

Insert> Create Motion Tween.-The 

Timeline should now look like this: 
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• -Choose Window> Controller to open the Controller and then rewind and 

play the animation to see what you've done so far. 

The photograph should slide In from the right and stop on the symbol's 

registration point. 

Tween rotation and a fade 

Now modify the motion tween to make the photograph fade in and rotate as 

it moves. You do this by specifying an alpha (transparency) setting of 0 in 

the keyframe where the photograph first appears, and by setting the number 

of rotations in the Tweening Properties dialog box. 

• -Select frame 1 in the Photo layer. 

• -On the Stage, select the instance of INTRO - PHOTO and choose Modify 

> Instance. 

• -Click the Color Effect tab in the Instance Properties dialog box and 

choose Alpha from the Color Effect pop-up menu. 

• -Move the Alpha slider to 0 and click OK. 

• -The photo becomes completely transparent (invisible). Only the selected 
t"' ...... " ........ "' .............. ' ............................ ~ 

~ ~ 
~ , 
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• -Make sure that the keyframe in frame 1 

in the Photo layer is still selected, choose 

Modify> Frame, and then clicthe Tweening tab. 
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• -Choose Clockwise from the Rotate pop-up menu, enter 1 in the Times 

box, and then clickOK. 

• -Use the Controller to rewind and play the animation. 

• -As the motion tween moves the symbol instance, it also rotates the image 

and changes the alpha settings between 0 and 100 to make the photograph 

fade in. 

• -Next, add the crown magnet to the top of the photograph. 

• -Select the keyframe in frame 20 in the Photo layer, and then drag an 

instance of the INTRO - CROWN symbol from the Library onto the 

photograph. 

• -Rewind and play the animation to make sure it works correctly. 

5.2.5 Add a frame action to stop the animation 

Although the animation you've created appears to stop at the last frame 

while you're in symbol editing mode, it will work differently when placed in 

the movie Timeline. Movie clip symbols loop as long as a movie plays 

unless you make the movie clips stop. 

Add a frame action to make this 

animation stop when it reaches the at I5l C ' 
~~~~~~~~~~ 

~ ~ IlliIINTRO -ANIMATION 

last frame. 

• -Select the Photo layer m the 

Timeline, and then choose Insert > Layer. 

• -Double-click the layer name, and then 

enter "Actions." 

• -Insert a keyframe in frame 20 in the 

Actions layer, and then choose Modify > 

frame Properties ' 
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Frame . 

• -Click the Actions tab in the Frame Properties dialog box, click + (plus), 

and then choose Stop from the Action pop-up menu. Click OK . 

• -you've now completed the INTRO - ANIMATION symbol. 

5.3.1 Create animated buttons 

The lesson, "Buttons," taught you how to create a 

. very simple button. In this section, you create a more 

complex button that animates when the mouse rolls 

over it and displays label text with transparency. To 

create an animated button, you place an animated 

movie clip symbol In one of the button's frames. 

Begin by creating the animation. 

• -Double-click the icon for the BUTTON - HOME symbol in the Library 

window to open the symbol for editing. 

• -Be sure to click the symbol icon, not the sYJnbol name, otherwise you 

just edit the symbol name. 

• -BUTTON - HOME is a partially completed button included to save you a 

few steps. 

• -Choose View> Show Frame to center 

the button in the window. Click the 

magnifier tool in the toolbox to enlarge the 

button if necessary. 

• -In the Timeline, name the first layer "Button." 

• -Insert a keyframe in the Over frame in the Button 

layer. 

Oilmop 
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• -Making sure the keyframe in the Over frame is still selected, click 

anywhere on the Stage with arrow tool to deselect the button image . 

• -Drag an instance of the BUTTON - CROSS symbol from the Library to 

the registration point in the BUTTON - HOME symbol. 

• -BUTTON - CROSS is a movie clip symbol that already contains an 

animation of a rotating cross. The instance of BUTTON - CROSS should 

line up exactly with the cross 

underneath. You can use the arrow keys to move the selection one pixel at a 

time. 

5.3.2 Add text transparency to the button 

First, add the transparent text layer to the button. 
~----~----------~------~ 

• -In the Timeline, insert a new layer and 1-=~=. ~S~cene~l~=-=::":":"::':"":":::;';=~~E:;::::;::;; 

name it "Text Transparency." 
• 

• -Select the Text Transparency layer in o 

the Timeline and drag it below the Button layer in the Timeline. 

• -Arranging layers this way makes the content of the Text Transparency 

layer appear behind the content of the Button layer. 

• -Create a keyframe in the Over frame in the Text Transparency layer. 

• -Select the BUTTON - BACKGROUND symbol in the 

Library, and then drag it so that its left side is on the 

registration point in the button. 

Now, make the button background blend nicdy with any background by 

applying an alpha setting to it. 
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• -With BUTTON - BACKGROUND still selected in the work area, choose 

Modify > Instance. 

• -C lick the Color Etfect tab in the 

Instance Properties dialog box, and choose 

Alpha from the Color Effect pop-up menu. 

• -Enter 50 ~s the Alpha value, and click 

OK. 

• -Making sure the Over keyframe in the 

Text Transparency layer is still selected, click the text tool. 

• -Use the text tool modifiers to choose Arial (Windows) or Helvetica 

(Macintosh), 18 points, bold, italic text. 

• -Enter the word "Home" over the BUTTON-

BACKGROUND symbol. 

• -You don't need to change the content of any other frames in the button. 

5.3.3 Duplicate the animated button 

The button you just created displays "Home" when you roll over it. Now, 

you need to create another button that displays 

"Contact" when you roll over it. To save time, you'll 

duplicate the BUTTON - HOM.E and then change its 

text. 

• -In the Library, click the BUTTON - HOME symbol, 

and then choose Duplicate from the Library Options 

menu. 

.-Name the duplicate symbol "BUTTON -

CONT ACT," and click OK. 
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• -Double-click the new BUTTON - CONTACT symbol in the Library to 

edit it. 

• -If necessary, Choose View> Show Frame to center the button in the 

window and use the magnifier tool to enlarge the button. 

• -Select the Over frame in the Text 

Transparency layer and use the text tool and 

modifiers to edit the text to read "Contact." 

• -You won't be able to see the buttons 

animating yet because movie clip animation 

does not work in the authoring environment. 

[jI s..., · 

• -If you want to see the buttons work, choose Edit> Edit Movie, drag an 

instance of BUTTON - HOME or BUTTON - CONTACT onto the Stage, 

and then choose Control > Test Movie. After the movie plays, close the 

movie window and delete the instance of the button from the Stage. 

5.4.1 Use editable text fields 

In Flash, you can place interactive controls and editable text fields inside 

symbols. In this section, you'll add basic data entry capabilities to the TEXT 

- CONTACT symbol. 

• -Double-click the icon for the TEXT - CONTACT symbol in the ' Library 

to open the symbol for editing. 

• -Create a new layer in the Timeline and name it "Data Entry." 

• -Select the first frame in the Data Entry layer in the Timeline. 

• -With the first frame in the Data Entry layer selected, click the IA I 1.tiI] 
text tool and the Text Field modifier. 
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- -Draw editable text fields for Name, Email, and . 

Comment. 

-6 -Use the arrow tool to adjust the Size and 

position of the fields. It's not important at this 

point to get them perfect. Notice that the square 

resize handle on an editable text field is on the 

field 's lower right corner. 

-7 -Using the arrow tool, select the Name text field 

and choose Modify> Text Field to open the Text Field Properties dialog 

box. 

- -Enter "Name" in the Variable box and click OK. 

- -Flash assigns the content entered in the editable text field to the variable 

whose name you enter here. You can then use the value of the variable in 

actions. 

- -Repeat steps 6 and 7 for the Email text field; name the variable "Email." 

- -Repeat steps 6 and 7 again for the Comment text field; name the variable 
"Comment", and click the Multiline and Word Wrap options before clicking 

OK. 

5.4.2 Add the Send button 

Now add the Send button to the TEXT - CO •• Z.T: 

CONTACT symbol. 

- -Make sure that the first frame of the Data 

Entry layer is still selected, and then drag an , ,~F. " D 
~. . .. .. . .., 

instance of the BUTTON - SEND symbol from the Library window and 

place it just below the editable fields. 
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• -Double-click the instance of the 

BUTTON - SEND symbol to open the 

Instance Properties dialog box. 

• -On the Actions tab, click + (plus) 

and choose Get URL from the pop-up 

menu. 

. EndOn 

~ " " ", ..tJ , " 
• -Type a URL in the box on the right, .;;..'< =::===~ ________ ;;;"':;"';;;';';';;';' ____ -" 
choose Send Using GET from the Variables pop-up menu, and then click 

OK. 

• -This sends the contents of all variables (the text entered in the editable 

fields) to the URL you specify. In a real application, you would need to 

create a valid CGI script at the URL location to receive the information, but 

for learning purposes you can enter any URL and it won't matter if there is 

no CG I script. 

• -At this point, you are done creating symbols for the movie. You're now 

5.4.3 Assemble the movie ' 

Using the symbols you've created so far, assembling the movie's content is 

easy. As you do this, you will learn more about using 

layers to organize the content of a movie. 

• -Choose Edit> Edit Movie. 

• -Name the first layer in the Timeline "Fridge." 

• -Drag an instance of the BACKGROUND - FRIDGE 

symbol from the Library window onto the Stage. 
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• -In the Timeline, insert a new layer above the Fridge layer and name it 

"Green Background." 

• -Make sure the Green Background layer is selected, and then drag an 

instance of the BACKGROUND - GREEN symbol onto the Stage. 

5.4.4 Add t he animated buttons 

Now, add the animated buttons you created. 

• -Insert a new layer·and name it "Buttons." Make sure 

it is the top layer in the Timeline. 

• -As you add layers, you'll want to be able to see all 

of them in the Timeline. 

• -Drag the lower border of the Timeline window so 

that all of the layers are visible. 

• -Select the Buttons layer and drag an instance of the BUTTON - HOME 

symbol onto the Stage. Because buttons respond differently to the mouse 

than other objects do, you need to disable buttons before you can select them 

and make changes. After you finish working on buttons, you can 

enable them again. 

• -Choose Control> Enable Buttons and make sure that Enable 

Buttons is not checked. 

• -Select the instance of BUTTON - HOME and move it into 

position. 

• -Make sure the Buttons layer is still selected in the Timeline, and then 

place an instance of the BUTTON - CONT ACT symbol below the 

BUTTON - HOME instance on the Stage. 
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• -To align the buttons, click BUTTON - CONTACT and hold down the 

Shift key as you click BUTTON - HOME to select both buttons. 

• -Choose Modify> Align and choose the horizontally left-aligned option. 

• -Choose Control> Test Movie to see the buttons animate when you roll 

the mouse over them. 

• -After the movie plays, close the test window to continue working in the 

movIe. 

5.4.5 Add the animated movie clip 

Now add the INTRO - ANIMATION movie clip you created. 

• -Insert a new layer in the Timeline and name it "Intro Animation." Make 

sure it is the top layer. 

• -Lock the other layers to make sure you're working only in the Intro 

Animation layer. 

• -Drag an instance of the INTRO - ANIMATION symbol from the Library 

window onto the Stage. 

• -Remember that the photograph image is completely transparent in the 

first frame on the movie clip, so the only visible part of INTRO -

ANIMATION is the registration point. 

• -Move the INTRO - ANIMATION instance 

so that its registration point is over the 

refrigerator. 

Remember that movie clip animation does not 

run in the authoring environment. 

• -Choose Control > Test Movie to see the 

movie with the animation working. 
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• -The animation only runs the first time the movie runs the test window. 

To see the animation again, close the test window and choose Control> Test 

Movie again. 

• -When you finish vIewmg the animation, close the test window to 

continue working in the movie. 

5.4.6 Add the text content layers 

The buttons you've added are supposed to make the text content appear in 

the green area on the right. Now you're ready 

to add the text content to the movie. 

• -Insert a new layer at the top of the 

Timeline and name it "Text Home." 

• -Select the keyframe in frame 1 of the Text 

Home layer and drag an instance of the 

TEXT - HOME symbol onto the Stage. Fit 

the symbol in the green area as shown here: 

• -To make it easier to see what you're doing, click in 

the Eye column of the Text Home layer to hide it 
.• ~C 

before you add the next layer. 

A red X appears to show that the layer has been hidden . 

• -Insert a new layer at the top of the Timeline and 

name it "Text Contact." 

• -Select the keyframe in frame 1 of the Text 

Contact layer and drag an instance of the TEXT -

CONTACT symbol onto the Stage so that it fits in 

the green area. 

Q TeKtHome -oc, X. • 
Q li'IIro AnIMIian . • . ;,. 
Q~ ;; .. -;:;'" ;;:--... 
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5.5.1 Use actions to control content 

You create interactive movies by setting up actions- sets of instructions that run 

when a specific event occurs. These events can be when the playhead reaches a 

frame, or when the user clicks a button or presses keys on the keyboard. 

Now you'll add actions to the buttons to make the appropriate text content appear 

when the buttons are clicked. 

5.5.2 Modify the instances of the text symbols 

Because actions can only target movie clip symbols, you begin by changing the 

instances of the text symbols that you just added into movie clips and giving them 

names. In the next section you use these names to identify the instances as targets 

of an action. Begin with the TEXT - CONTACT instance. 

• -Make sure the Text Contact layer is still selected in the Timeline, and then 

double-click the TEXT - CONTACT symbol instance on the Stage to open the 

Instance Properties dialog box. 

• -Click the Definition tab, and then click Movie Clip as the behavior. 

• -Notice that an Instance. Name field appears under Instance Options. 

• -Enter "Contact" as the instance 

name and click OK. 

5.5.3 Now, change the 

instance 0.( the TEXT -

HOME symboL 

• -In the Timeline, click the 

visibility controls to hide the Text 

Contact layer and show the Text 

1m! BUTTON· CROSS 

~ BUTTON · HOME 

~ BUTTON · SEND 

~ CROSS IMAGE 

1m! INTRO ·ANIMATION 
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Home layer. 

• -Remember that the visibility controls for each layer are in the column below the 

eye icon in the Timeline. 

• -Select the Text Home layer in the Timeline, and then double-click the instance 

of the TEXT - HOME symbol on the Stage to open the Instance Properties dialog 

box. 

• -Click the Definition tab, and then click Movie Clip as the behavior. 

• -Enter "Home" as the instance name, and click OK. 

5.5.4 Add an action to the BUTTON - HOME button 

Now you can add an action to the BUTTON - HOME button that displays the 

Home text and hides the Contact text when the button is clicked. 

The buttons should still be disabled so that you can select them and make changes. 

• -Choose Control> Enable Buttons and make sure that Enable Buttons is not 

checked. 

• -Make sure the Buttons layer is selected in the Timeline and unlocked, then 

double-click the BUTTON - HOME button on the Stage to open the Instance 

Properties dialog box. 

• -On the Actions tab, click + (plus) and choose Set Property from the 

pop-up menu. 

• -Choose Visibility from the Set pop-up menu. 

• -Click the button to the right of the Target box and choose Target Editor from 

the pop-up menu. 

If you make a mistake, you can click the minus 

button (-) to remove the selected line in the action 

T"II]"I frl,IIJI ! [3 , 



and then re-create the statement. You can also choose Edit> Undo . 

• -Click OK to close the dialog box. 

5.5.5 Add an action to the BUTI'ON - CONTACT button 

Now give the BUTTON - CONTACT button an action that displays the Contact 

text and hides the Home text. 

• -Double-click the BUTTON - CONTACT button on the Stage to open the 

Instance Properties dialog box. 

• -On the Actions tab, click + (plus) and choose Set Property from the pop-up 

menu. 

• -Choose Visibility from the Set pop-up menu. 

• -Click the button to the right of the Target box and then choose 

Target Editor from the pop-up menu 

• -In the Target Editor, double-click Contact to select it as the target, and then 

click OK. 

• -In the Value field on the Actions tab, type 1. 

Now, add a second statement that hides the Home text. 

• -Click + (plus) and choose Set Property again from the pop-up menu. 

• -Choose Visibility from the Set pop-up menu. 

• -Click the button to the right of the Target box and choose Target 

Editor fi'om the pop-up menu. 
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5.5.7 Add a frame action 

Hiding layers in the Timeline has no effect on content when you run the movie 

outside of the authoring environment. To hide both the Home and Contact text 

when the movie starts, add a frame action to the movie. 

• -Create a new layer in the Timeline and name it "Frame Actions ." 

• -Double-click the first frame in the Frame Actions layer to open the Frame 

Properties dialog box. 

• -Click the Actions tab and choose + (plus), and then choose Set Property from 

the pop-up menu. 

• -Select Visibility from the Set pop-up menu. 

• -Click the button to the right of the Target box and choose 

Target Editor from the pop-up menu. 

• -In the Target Editor, double-click Home to select it as the target, and then click 

OK. 

• -In the Value field on the Actions tab, type 0 (ze~o) . 

Now, create a new statement in the action by copying the existing statement. 

• -Press Control+C (Windows) or Command+C (Macintosh) to copy the first 

statement in the action. 

• -Press Control+V (Windows) or Command+V (Macintosh) to paste a copy of 

the statement into the window. 

-This creates a copy of the line you just 

created. You only need to change the 

target. 

Set Pr 

.......... - ------' ~ 



5.5.7 Add a frame action 

H1d1ng layers 1n the Timeline has no effect on content when you run the movie 

outside of the authoring environment. To hide both the Home and Contact text 

when the movie starts, add a frame action to the movie. 

• -Create a new layer in the Timeline and natTie it "Frame Actions ." 

• -Double-click the first frame in the Frame Actions layer to open the Frame 

Properties dialog box. 

• -Click the Actions tab and choose + (plus), and then choose Set Property from 

the pop-up menu. 

• -Select Visibility from the Set pop-up menu. 

• -Click the button to the right of the Target box and choose 

Target Editor from the pop-up menu. 

• -In the Target Editor, double-click Home to select it as the target, and then click 

OK. 

• -In the Value field on the Actions tab, type 0 (zero). 

Now, create a new statement in the action by copying the existing statement. 

• -Press Control+C (Windows) or Command+C (Macintosh) to copy the first 

statement in the action . 

• -Press Control+V (Windows) or Command+V (Macintosh) to paste a copy of 

the statement into the window. 

-This creates a copy of the I ine you just 

created. You only need to change the 

target. 

Set f'lQPef1 "!Contact". Vi I - "0" . ~.t IV;.ibiily ::OJ '" 
I ,..,.,..-___ _ 
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• -Use the Target Editor to change the target from Home to Contact. 

• -The action should look like this: 

• -Click OK to close the Frame Properties dialog box when you're done. 

• -At this point, you are done with the content of the movie. Your movie should 

look like the Tutorial Finish.tla example. 

Test the Movie 

Test the movie Now that the movie content is complete, you can test the movie to 

see all of its features. 

• -Choose Control> Test Movie. 

• -While testing the movie, enter some data in 

the Contact fields. Enter more than one line in 

the Comment field to see the lines word wrap. 

• -Choose Control> List Variables to display 

the Output window. 4 Click Send to see it how 

the variables work. The Output window displays the data that Flash sends to the 

server. 

IMovie Clip: Target=" levelO! Contact" 
. ~ariable _levelO! Cont~ct : Name = "myname" 

Variable levelO!Contact:Email = .. myaddreaa@myaerver.com .. 
I -
,Variable levelO! Contact:Comment = "You people are great ! " 
I -
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A functioning application would require additional actions, such as an action that 

clears the fields after sending the data, but this example should give you a basic 

understanding of how you can use Flash to send data to a server. 5 Close the 

Output window, and then close the window in which the movie is playing. You're 

now ready to publish the movie. 

5.5.8 Publish the movie 

The movie's content is now complete. To play the movie in a browser, you need to 

export it as a Flash Player file. Flash has been doing this for you every time you 

use the Test Movie command. 

When you create a web site with Flash, you often need to include several 

accompanying files. In addition to a Flash movie, you must create an HTML 

document that opens in a browser and runs the Flash movie or displays other 

Flash-generated graphics. You may also want to create an animated-GIF version of 

your movie or a JPEG image to display if the Flash Player is not installed. 

Use the Publish command to export to all the supported formats at once and create 

an HTML document with all the required settings. 

• -Make sure you've closed the separate window in which the movie was playing, 

and then choose File> Publish Settings. 

• -On the Formats tab, select Flash and HTML. Make sure that the Use Default 

option for file names is selected. 

• -Although you are not using any additional formats for this tutorial, this is where 

you can choose additional formats such as JPEG or QuickTime. 

3 -Click the Flash tab. 
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• -You don't need to change any of these options now, but you may need them 

later for your own work. You may, for example, want the layers to appear from the 

top down instead of the bottom up as they do in this movie. 

• -Click the HTML tab. 

• -There are several ways to control Flash movies with HTML code. The: settings 

in the HTML panel let you define the most common and useful settings, including 

the size, positioning, color, and quality of the movie. Flash inserts the settings you 

choose in a template document. Flash includes several template documents 

containing HTML code for useful features like browser detection. 

• -To complete this tutorial, you will choose a simple template that does nothing 

except display the Flash movie specified. 

• -Choose Flash Only from the Template pop-up menu. 

• -Deselect the Loop option. 

• -This prevents the movie fTom playing over and over. 

• -Click Paused at Start so that no check mark appears in the check box. 

• -If you leave this option on, the movie does nothing until an action starts the 

movie. You want the animation to playas soon as the page is loaded, so this option 

should be off. 

• -YOll don't need to change the default values for the remaining HTML settings. 

• -Click Publish and then click OK to close the Publish Settings dialog box and 

generate the specified files. 

• -Flash generates the new files and stores them in the same folder as the movie 

file. 
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5.5.9 Play the movie inside a browser 

Your work in Flash is complete at this point. Now you can see how the movie 

plays inside a browser. 

• -Open a browser such as Netscape or Internet Explorer. 

Q Ei<! f.d1 ~,y ~o t <"',"'ncOl" , UeiJ 
• -Open the HTML file you just created,. ',: e~:l. ;" ,-. ;1 R. I><YJ H(vt~ ~ e..,:h WNJ r.<-. ~ 

~ " .. i.J OeW-~~b h ~~I'J..:.-ll.t(v?!>,)I,", f Y.-:!M .x'''"~'f4~&'· 11i~1~;.:aIF~. :~t·".:·~ 
- In Netscape Navigator, chose File > Open 

Page, and then browse to locate the file. 
o 
• -Tn Internet Explorer, choose File > 

Open, and then browse to locate the file. 

• -The HTML file is in the same folder as 

the movie file and has the same name as the 

movie, with an . htm or . html file extension. 

The movie should run inside the browser window j list as it did when you used the 

Test Movie command. 
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HTML 

( Hyper Text Markup Language) 

6.1 Introduction To HTML 

Tim Berners-Lee, founder of the World Wide Web, offers this 

definition:" Hypertext Markup Language (HTML) is a simple data fonnat 

used to create hypertext documents that are pOltable from one platform to 

another" . This definition was taken from a November 1995 memorandum 

from Berners -Lee regarding HTML 2.0. 

It is reproduced in full at ftp://ds.internic.net/rfc/rfcl866.txt. 

Portability and simplicity are the two hallmarks of HTML. We can create 

HTML files on any computer that has Web browsing software. If we have 

web browsing software and a connection to the Internet, we can also view 

any HTML files available on the World Wide Web. We can move HTML 

files from one type of computer to another with no loss of meaning. HTML 

is and easy language to use. 

HTML was developed specifically for use on the Web. We are not restricted 

to using HTML on the Web, however; HTML has a wide range of 

applications outside that venue. Companies use HTML as a document 

format for internal use, and individuals use HTML to facilitate the exchange 

of documents . More than 30 million HTML documents are available on the 

Web, and HTML and the web have become almost synonymous in the 
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minds of the general public. HTML and the Web are not same, though. 

HTML is the standard method we can use to put infonnation into a 

universally readable fonnat on the Web. 

6.2 History O/Hypertext 

The obvious first question when defining HTML is "what is hypertext?" 

Start by looking at the word it self. Hyper has a connotation of extra or 

beyond when used in words such as hyperactive and hypersensitive. Text 

refers to a written block of language, whether it is prose, poetry, a glossary, 

or any other form of written infonnation. Ted Nelson coined the tenn 

hypertext in 1965 to refer to textual information that is not limited by the 

bounds of the text itself. Hypertext can be connected to other texts, and it 

can be navigated by a system of links in non-sequential order. 

Hypertext goes beyond plain text. It is not designed to be read in a linear 

fashion, form beginning to end, but selectively, as readers require certain 

information. Hypertext is easier to demonstrate than to define. We are 

probably familiar with a basic hypertext system the online help that most 

software programs today feature. We can go directly to the subject on which 

we want information, and most online help entries also include links to 

related topics. 

6.3 The Best Online Help Programs 

If we can't find what we are looking of with one method of searching, 

another method usually works. When using online help, if we already know 

to implement a certain feature , it is not compulsory we have to page through 

an explanation of that feature for the fifteenth time. Another example of a 

hypertext system is an encyclopedia ·on CD-ROM print encyclopedias has 

always encompassed a rudimentary sort of hypertext. Readers choose 



specific articles; they rarely (if ever) read and encyclopedia from beginning 

to end. 

Many articles include suggestions of other article, to read . Choosing the text 

article probably means that we want to return our CUlTent volume to the 

shelf, pick up another volume. Search for the desired article read it, see the 

articles suggested next, and then perhaps repeat the process again and again. 

Encyclopedias on CD-ROM streamline this process significantly. We can 

jump in then investigate the ancient Phoenicians. 

Reading in the conventional manner is still possible, but hypertext reading is 

encouraged by the medium itself. The antithesis of hypertext is an ancient 

scroll, which requires the reader to unfurl the text in its entirety from the 

beginning to the desired point in order to locate a specific passage. Tn 

contrast, a printed book that includes a table of contents and an index 

encourages a certain degree of nonlinear exploration. The reader can look 

for specific infonnation and jump between topics. The use of hypertext is a 

natural response to the information explosion of the 20th century. 

In the 16th century, some people might 'have read a considerable percentage 

of all the books in existence and had at least a general knowledge of most 

academic subjects. Plodding through several volumes to find a specific fact 

might have been acceptable pastime for person of leisure. No one today, 

though, could possibly be expected to have read all the books, journals, 

newspapers, arid other information sources cUlTently in existence in order to 

keep up to date, even in a specialized field . 

As Vannevar Bush, often considered the father of hypeltext, wrote in a 1945 

article, " The investigator is .staggered by the findings and conclusions of 

thousands of other workers conclusions which he cannot find time to grasp, 
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much less to remember, as they appear.' (Bush ' s artic le was first published 

in the July 1945 iss ue oCThe Atl clllti c Monthly, and it was republished , with 

permi ss ion , at the following address: 

http ://www . isg.sfll .caJ-~,duch ier/mi sc/vbush/. ) 

Bush ' s reflection on the increas ing vastness of human knowledge is even 

truer today. But the development of workable hypertext systems that 

categorize hu ge areas of knowledge is making the task of finding specific 

fasts and information much easier than it once was. Properly designed 

hypertext facilitates index in g and categorization . Researchers in any subject 

area understand how he lpful a good index can be . Imagine the indexes of 

tens of thousands of books and artic les being made available in a huge 

database, and all this information being accessib le with a very user-friendly 

search mechanism. 

Then ima gine be in g able to search by any keyword in any text or group of 

texts. The Web, at its best, includes such Lin indexed system, and your 

documents can be pmt of it. Search engine slLch as Alta vista, at 

http ://a)avista .digital.com . now we perform keyword searches of all 

documents availablc on the web (or at least the majority of these 

documents) , which have been made available to Alta Vita's indexing robots. 

Il ypert ex t CIt it s best ca n allow us to pinpoint the exact information required , 

no matter w hat the rcst of the docllment or docllments look like. However, 

hav in g our docllments in hypertext format is no substitute for basic writing 

sk ill s . In fact, clear writin g Ill ay be more important in respect to hypertext 

doculllcnt than it is 1'01' regular doculllcnts. \Vith hypertext, we can't rely on 

our lIser knowi ng or recogni z in g the underlying context we ' ve built up 

e lscwhere, as we C<ln w ith ;;1 rcgular documcnt. To maXl1TI1 Ze th e 
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effectiveness of our hypet1ext documents, concept of clarity at the forefront 

when we create our documents, we're less likely to experience problems 

later. 

I n the context of modern computers, the term hypertext is something 

of a misnomer. Becallse graphics and other media, not just text, frequently 

playa major today ' s hypertext system. The term hypermedia, also coined by 

Ted Nelson, more accurately describes the type of structured documents that 

let your navigate seamlessly among text, graphics, sounds, and video. For 

example, if we perform a search for Mozart on a CD-ROM encyclopedia, 

we'll probably be able to hear an excerpt of one or more of the composer' s 

works, in addition to reading his biography and linking to related at1icles . 

Although the web was largely (but not entirely) text based at the time of its 

inception in 1990, other forms of information are playing an increasingly 

important rote . The term hypertext Markup language is probably here to 

stay, but keep in mind that HTML is a document format. 

6.4 History OfHTML 

Today, the advantages of hypertext are apparent to many people. However, 

hypertext was a little lIsed concept before the widespread use of personal 

compllters at least ill thc scnse of the powelful implementations you see to 

day. The hypertext system proposed in 1945 by Vanneva Bush. The memex 

involved a cumbersome apparatus that would have lIsed, among other things, 

a microfilm machine and various photography techniques . 

Before CD-ROM drives were first installed in PCs In the late 1980s, 

relatively few cheap and easily searchable storage mechanisms were 

available for vast quantities of data. The storage capacity of hard drives was 

millimal compared to today ' s standard drives, which can hold gigabytes of 
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data. Microfilm can hold a great deal of information, but performing 

searches ill mi cro film is tim e co nsumin g and tediolls . 

Time Remers Lee published a paper ca ll " information Mana ge ment: A 

Proposa l" The origin al proposa l is avai labl e at the W3C site at the following 

address: 

l.!1tgj/www. w3 .0rg/l2!lb/wwvyLh i s t o ryQ9~9/pr(2RO S(}1. ht Jill 

III that proposal , HCl'll ers I,ce describes Ihe dilTi culti es of mana gmg 

information flow e ffi ciently among the more than 2000 staff members of 

CER N, in a vvorkplace ranging over several geogTaphic locations and 

illvol vin g hi gh employee tlll'llover. The use of several different computer 

systems compli cated fil e and information sharing, because the formats often 

were illcompatible. 

Berners Lee proposed a system thai wo uld allow informat ion to be shared 

across a variety of pbtforms. The information was to be accessible 

regardless of the type of computer the user had . Furthermore, in order to aid 

lIsers who needed spec ifi c and prec ise illforlllation ., a ll information was to be 

presented in hypertext format and cross-re ferenced to other documents. The 

genius of Berners Lee was to propose the marrIage of cross platform 

comp(ltibilil y (lnd inforlnlltion presentecl on in hypert ex t lonnat. Even more 

significantly, he proposed a system that would actually make such 

information interchan ge feasible. The 1989 paper was the genes is of the web 

(the terlll World Wide Web was developed ill 1990). The mechani sm for 

putt in g in format ion int o hypert ex t form at deve loped into HTML, variolls 

computer-networkin g protocol s ha ve been developed to facilitate 

cO IllIllUni c(l ti oll betwee n entire ly different syste ms . We ca n read more about 
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the development and nature of these protocols at the World Wide Web 

Consortium Web site at http://www.w3 .org. 

6.4.1 What Is HTML? 

HTML is the format in which we can put our information for display on the 

World Wide Web. Every HTML file is an ASCII text file (also called a plain 

text file), even if it refers to other forms of media, such as sound or graphic. 

We can open any HTML file in a text editor or even a word processor. To 

get an HTML file for viewing, connect to Intel;net provider, and then visit 

the Web site. 

Follow the instructions in browser to save the HTML file, which combines 

the actual text we can see on the site with a bunch of codes. In Netscape, 

select file! Save As. Once we have done this, we can see the actual coded 

HTML file. Open the newly obtained HTML file in a text editor or word 

processor, we can see it. In the text file, we can see that all the HTML 

instructions are inside angled brackets like this: <TAG>. 

Our browser interprets these instructions to mean that the textual 

information should be displayed in a certain manner. If other media (such as 

sound, graphics, animation, and video) are referred to in the HTML file, our 

browser will display them (if it has that capability). If our system can't 

interpret capability, we won't hear any sound files. 

If our browser can't display images, we won't see any images. Ideally, we 

will design our Web pages so that anyone with any browser can make sense 

of them, even if they can't access all the information. HTML is designed in 

away that accommodates these differing capabilities. If pages are coded 

properly, people who can't see images or video will see descriptive text 

instead. 
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6.4.2 HTML Is Not A Page Description Language 

Before we discussion further detail what HTML is and how it works, it 

would be useful to consider what HTML is not. HTML is very powerful, but 

there are some things it can't do. Many inexperienced Web author think of 

HTML as a formatting language that let we place images and text on the 

screen as preciselyas we can create a document on paper. 

But HTML isn't page description language. A page description language, 

such as those used in page market and similar programs, describes to the 

tenth of an inch where margins should go, the exact size style of font that 

should be used, the precise color of the text, and so on. HTML can't make 

those kinds of formatting decisions. 

6.4.3 Htmlls Not A Programming Language. 

HTML is not computer programming language. It isn't like C++, BASIC, or 

FORTRAN. With computer programming languages, we write programs, 

but with HTML, we form text and other media for viewing. Formatting our 

documents in HTML has many similarities with formatting our documents 

with a word processor. The main difference between formatting a document 

in HTML and formatting a document in our word processor is in how we 

implement that formatting. 

In our word processor, we probably indicate paragraph indicate paragraph 

breaks directly. We decide whether each paragraph should be indented, how 

much it should be indented, and how much space there should be between 

paragraphs. With HTML, we can indicate the start and end of a paragraph, 

but we cannot know how the user's browser will display paragraphs. 
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Any well-known browser, however, will display paragraphs in such a way 

that the user can see paragraph breaks. Simi larly we might choose boldface 

in our word processor to emphasize an important point. But in HTML, our 

browser' s and computer's capabilities determine whether this type of 

emphasis is indicated by a larger font, a different color, italics, boldface, or, 

in the formation we use in our word processing documents probably carries 

a meaning that has an HTML equivalent, HTML sometimes has an aura of 

mystery, and its secrets are presented as being incredibly arcane. 

HTML is actually simple when we think carefully about how to structure our 

information. Many Web page authors would argue convincingly that 

formatting a document in HTML is actually easier that preparing a document 

in our word processor. 

6.4.4 Test And Tags 

Tags are instructions to browsers, telling them how to layout text, what 

graphics to display where, what distant pages to link to, and a variety of 

other things. A few basic rules are common to all: 

Each tag must be enclosed in <angle brackets>. 

Lower or upper case letters can be used. 

Most tags come in pairs. 

Browsers ignore any spaces or now lines around tags . 

<HTML> . 

Every HTM L document starts with the tag 

<HTML> and ends with </HTML> 
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6.4.5 Headings 

There are sets of tags that can be used to define headings over a range of 

sizes. They all start < 1-1 .... followed by a no between 1 to 6> . 

<TITLE> 

Every page should have a title. This is not the text that appears at the top of 

the page we do that with a <H 1 > tag. The title is what appears on the title 

line of the browser window, and what would he used as a bookmark if 

anyone book marked our page. It is used in the standard way: 

<TITLE> 

Every page should have a title. This is not the text that appears at the top of 

the page we do that with a <HI> tag. The title is what appears on the title 

line of the browser window, and what would be used as a bookmark if 

anyone book marked our page. It is used in the standard way: 

<TITLE>THIS IS MY HOME PAGE </TITLE> 

<ADDRESS></ ADDRESS> 

These tags have s double effect, setting the text into italic and placing it on a 

new line. The convention is to use these tags only with our e-mail address. 

That would normally go at the bottom of our home page. 

516.4.6 Paragraphs And Breaks 

When a browser reads the text in an HTML document, it ignores all spaces 

(apart form those between words!) tabs and carriage retunls ([Enter] key 

presses), <B ... > headings will be placed on separate lines. But if we want to 

break blocks of body text into paragraphs, or even just start a new line, you 

have to use one of these three tags. 

<BR> 
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This is a line break and marks the statt of a new line. Note that <BR> stands 

alone there is no closing tag. 

This marks the start of a new paragraph and places a blank line before it. We 

can equally well place it at the end ofa piece of text, at the start of the next, 

or in between. <P> is a second stand along tag. 

<HR> 

<HR> stands for horizontal rule. This is third stand alone tag and separates 

paragraphs by drawing a line between them. The basic line will be in, with a 

shaded effect, and extend almost the full width of the window. 

The above tags can be seen in this example: 

<HTML> 

<Title> 

My Home Page 

</Title> 

<Hl>Designing a Web Page</Hl > 

<HR> 

<H2>SITES OF MULT AN</H2> 

Multan is the ancient city of Pakistan 

<BR> 

<p> The history of Multan prior to the arrival of the Arabs in the 

8th century A. D. is obscure. Alexander is said to have passed 

through the district in about 325-326 B.C., but his route cannot be 

traced. It is probable that Multan was the city of Malli which 

A lexander stormed and where he was wounded 

</P> <H2>SHRINES </H2> 

</HTML> 
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6.4.7 Further Text Formatting 

<Font Size = value> 

The <H ... > tags are a simple but effective way .of creating headings, but if 

we want more control over the size of heading text, or want to vary the size 

of text within a paragraph, we must use the <Font Size = ... > tag. 

The size value can be from 7 down to 2 with 7 being the largest size at 36 

points of MSWORD. Note that the values run in the opposite direction to 

headings, where <HI> is the largest. 

6.4.8 Aligning Text 

Body text and headings are normally aligned to the left edge, but both can be 

set in the center or to the right, if required. To set the alignment, write inside 

the <H .. > or <P> tag the key word ALIGN = followed by Center, Right, 

Left. For example: , 

<H3 ALIGN= "RIGHT"> 

6.4.9 Adding Emphasis 

I f we want to emphasize a word or phrase in our text, we can use these 

pairs of tags. 

<B> .......... </8> Sets text to bold. 

<1> .......... </1> Makes text Italic. 

<TT> ........ </TT> This creates a typewriter effect by setting text in courier. 

<Strong> </Strong> 

<B>, <I> and <TT> are physical tags they only work if the visitor's browser 

can display bold, italic or courier fonts. <Strong> is an example of a logical 

tag one whose effect can be redefi ned at the receiving end. In practice, it 

will usually have the same emboldening effect as <8>. 

<Emphasis> </Emphasis> 
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This is the logical equivalent to <I>, and has the advantage of being more 

easi ly spotted when we are checking through our code for mistakes. The 

other logical tags are <Definition>, <Citation>, <Code> and <Keyboard>. 

They are all used in the same way as <Strong>. <Blink></Blink> 

This makes text flash one way to catch people ' s attention. We can try this 

HTML code to see the effect of the styling tags. 

6.4.10 Preformatted Text 

<PRE> ..... <!PRE> 

These tags define preformatted text, and tell the browser to include the 

spaces tabs and new lines just as they are written. Within the <PRE> block, 

the text is displayed in courier. This font does not use proportional spacing 

i.e. every letter and space occupies the same width on screen. This means 

that we can use spaces to push text over to the right and get it exactly where 

we want it. Tags are still obeyed, within the <PRH> block, so we can 

include heading, font sizes and alignments as usual. Use <PRE> for price 

list, poems or other text where the pattern of tabs and spaces are essential. 

6.4.11 Co lor 

Normally the text appears in black on a pale gray background. We can use 

colors: 

55<Body bgcolor=value text=value> 

We can set the color of the background and of the text, by including either or 

both phrases in the <body ... > tag. These settings apply to the whole 

document. 

<Font color=value> 

This changes the color of text, just as <Font Size = > sets its size. In the 

same way, when we have done with a color, we can switch to a new one 
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with another <Font color> tag or restore the previous color with </font>. 

Colors are selected by giving the values, in hexadecimal, of the Red, Green 

and Blue components. 

6.4.11.1 Color Values 

Giving what looks like a 6- digit hexadecimal number sets colors. It is 

actually 3 numbers, each of two digits, which set the brightness of the Red, 

Green and Blue 3 numbers, each of two digits, which set the brightness of 

the red, Green and Blue components in that order. On a 24-bit color display, 

each of these could be a value between '00' and 'FF'. in practical terms, it is 

enough to think of the light values as being '00' of '80' for dipped and 'FF' 

for full beam. To set. colors for the document, use the keywords 

BGCOLOR=" and lor TEXT=" with the appropriate values, inside the 

<BODY> tag before any of the headings or body text. To set the color for a 

section of text, use the keywords COLOR inside preceding hexadecimal 

digits A-F. 

Use code like this to test out the range of colors: <html> 

<body bgcolor=fffff text = 000000> 56<htm> " <body> bgcolor - fffff text 

=000000 <H I> color text<hi> <font> size=5> Let's get bright and cheerful 

<br> <font color=ffOOOO>red <BR> <font color=OOffOO>Green 

<BR><font co 10r-OOOOft> Blue 

<BR><FONT> Back to green, <IFont>then red,<IFONT> then to 

black</body></HTM L> 
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6.4.11.2. Link Colors 

Links are normally displayed in blue, if they have not yet been used, or deep 

purple if they have. If we change the color of our background, or of your 

text, the links may not stand out as well as we would like. 

<BODY ... LINK=value ALINK =value VLINK=value> 

Any or all of these options can be used to set the co lor of the text that leads 

to: 

An unvisited link (LINK), 

The active link (ALINK), 

A visited link (VLINK) , 57The color values are the same as for other 

settings. 

6.4.12 Graphics 

Used thoughtfully, graphics can make a Web page a much more attractive 

and interesting place. 

6.4.12.1 Linking An Image 

<IMG SRC = "Filename"> 

This is the basic tag linking and image into our page. Used without 

qualification. It places the image against the left edge, directly after any text, 

and with later text starting to its right. 

For example 

<HTML> . , 

<H2> 

Graphic </H2> 

< I NG SRC = "flower.jpg"> Flower 

<P> </HTML> 
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6.4.12.2 Positioning 

<p> and <H .... > tags used with images sets the vertical position in relation to 

surrounding text. There are three options: Top, Middle and Bottom. Bottom 

is the default, placing surrounding text at the bottom of the image. If there is 

following text, and it is too long to lit in the remaining space to the right, it is 

wrapped round to below image. 

<CENTER> 

<CENTER> can be used as used as a tag in its own right to align text and 

graphic in the center of the display window. When used in this way, a 

closing </CENTER> tag is needed at the end of the centered material. 

6.4.12.3 Spacing 

There are two options that can control the spacing around graphics. The 

default settings are to leave a space of 10 pixels spacing to the left and right; 

VSPACE = set the pixel spaces above and below the image. Note that we 

cannot control left and right, or above and below spacing independently. 

6.4.12.4 Adfusting The Size 

HTME gives us two alternative ways of setting the size: 

Fixed, where the displayed size is given in pixels, it helps if we know the 

size of the original; 

Variable, where the size specified as a percentage of the screen size. The 

advantage of the variable approach is that we can be sure that our image will 

fit on screen, whatever the size of our visitor's windows. 

HEIGHT=value WIDHT=value 
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The same tag options are used for fixed and variable resizing. The only 

difference is in how we give the values. For fixed sizing, simply give the 

pixels as plain numbers; 

HEIGHTS 100 WIDTH-75 

Sets displayed size of the Image at 100 x 75 pixel. If we want to avoid 

distorting the shape, you must know the original pixel size, so that you can 

calculate the new values. For variable sizing, give the value as a percentage 

of the screen height or width and follow the number with a% sign. 

HEIGHTS 50% 

Sets the image to be sca led down so that it fills half the height of the browser 

window. 

6.4.12.5 Background Images 

Another striking use for an image is as a background to our page. The trick 

here is not to use a large, full-page picture, which will take an age to 

download, but to use a small image. HTML automatically repeats any image 

used as a background; so we can get a full screen from the tiniest images. 

With any kind of background pattern, it is important that the pattern does not 

become too dominant - it is supposed to be a background after all. The 

answer is either to use a very sparse pattern, or pale colors 

<HTML> 

<HEAD> 

<TITLE> BACKGROUNDGRAPHIC 

</TITLE> 

</HEAD> 

<BODY> 
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<BODY BACKGROUND="flowers.gif TEXT FFFOO> 

<FONT S IZE=7> 

<FONTSIZE=5> 

<P>The simpler the background, the better will be the effect. 

</80dy> 

</HTML> 

6.4.12.6 File Formats 

GIF (Graphic Information Format) was established by CompuServe as the 

standard for graphics used in their communication services. It was chosen 

because its built in compression produces very compact files. For this same 

reason it has been adopted as a standard for Web browsers. The second 

widely used standard format is JPEG (Joint Photographic Experts Group) on 

PCs the files have a jpg extension. This also produces compact files. 

6.4. 12. 7 Links 

Graphics are fun, formatted text reads well, but when it comes to the crunch. 

6.4.12.8 HREF 

The key word for links is FRER (hyper text reference). This identifies the 

target page, or point within a page. But it can't be used by it self. It must be 

anchored to a piece of text or a graphic, so that there is something to click on 

to pick up the link. The anchor tags are <A .... > and </ A> which mark the 

start and end of the link text. The two are used together to create the link and 

it's jumping'off point. For example; <A HREF = http//www:yahoo.com> 

Go to Yahoo </ A> 
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6.4.12.9 Links To Other Pages 

These are the simple to handle, specially where the link is to the home page 

of a well established site. Mere is an example <AHREF = " 

http://www.lycos.com .. > Lycos</A> 

6.4.12.10 Links Wi t hin Documents 

If we want to jump from one part of a document to another perhaps from a 

menu at the top, down to a section, or back up to the top, we have to define 

jump points. These are marked by a variation on the anchor tag: 

<A NAME =jump point> jump Point text </A> 

The jump point can be a single word or phrase, and we can write it in quotes 

if we want to make it stand out more clearly in the source code. It will not be 

identified in somewhere to go from. The <A NAME = ... > tag can therefore 

be wrapped around and existing heading, or embedded in body text at the 

right place. 

6.4.12.11 Links And Images 

Linking tags do not have to be attached to text. We can anchor them to 

graphics, replacing the text with an <IMG SRC ... > tag. 

<A HREF = www.nt.scape.com> <IMG SRC=logo.gif 

</A> That could create a link to Netscape ' s home page, based on the image 

of their logo. 

6.4.12.1 2 List And Lines 

To display sets of links or other short items it is better to use bulleted or 

numbered lists. To divide text into clearly marked sections limes can be 
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drown between them. Here we cover the tags and techniques that control 

these. 

List 

There are three types of lists, with bullets, with number or letters and lists of 

terms definitions. For the first two types the techniques are the same, with 

the only difference being in the tags that define the list type. The default 

settings give you round bullets (0) and Arabic numerals (1,2,3), but optional 

keywords inside the tags can be used to set a different bullet or numbering 

style. 

Bulleted Lists 

A bulleted list is set up with the tag <UL> to mark its start and, </uL> to 

close it. Each item in the list is preceded by the tag<Ll> (list item). This 

needs no closing tag. 

Variations 

With a plain <UL> tag, the bullets are filled circles. The phrase "TYPE= key 

word", can be added where the keyword is either WQUARE, DISC or 

CIRCLE. SQURE gives us a filled square; DISC produces a filled circle, the 

default bullet. 

Nested lists 

Lists can be' nested' one inside the other, to gIVe us several levels of 

indents. The same tags are used as for simple lists but we must put a </uL> 

tag at the end of each inner level. Note that you can use different bullet 

styles for the inner and outer lists. When writing nested lists, we will find it 
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helpful to indent our inner list items in our code. It shows the structure more, 

Clearly, and it makes it easy to do a quick check that each opening <UL> tag 

has a matching 

<HTML><H3>ANIMALS </H3 > 

<UL type=square> 

<Ll > Hen 

<LI > Goat 

< LJ> HORSE 

<L l > CAMEL 

<L l> DOG 

</UL> 

<UL type =disc> 

<Ll> PIGEON 

<L l > PARROT 

<ILl > </UL> 

Fancy bullets 

Bored with blobs in your lists? We can create fancy bulleted 'lists' by fitting 

our own bullet images at the starts of lines. These won't be proper lists, as 

defined by <OL> or <UL> tags, but they will look good on screen. It is a bit 

more work, as we have to make the bullets and set the indents which is, in 

effect, what the list tags do for us but the results are worth while. 

Line Styles 

The basic <HR> line is two pixels deep, stretches more or less the full width 

of the window, and has a shaded effect. These aspects can all be changed by 

options in the <IIR> tag. 
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Size = value 

This set the thickness of the line, counting in pixels. The size must be at least 

2 if we want shade effect. Over abo ut 8 pixels, it looks less like a line than 

a box. 

Width - va lue 

This set width of the· line. As with the WIDTH option of images, you can 

e ither count in pixe ls or set it to a percentage of the browser window's 

width. Unless we want the line to match a heading or image, or we are 

creating a pattern of lines, it is usually best to set the width as a percentage. 

We then get the same effect, whatever size window it is viewed in. 

Align = value 

This sets the line to the left, right or in the center of the screen. It can only be 

used if the width has been set. 

NOSHADE 
I f this keyword is used, the I ine is shown as a plain dark line. The effect of 

setting the s ize and (pixe l) width can be seen in the example below : 

<HTML> 

< H2> horizontal rules </1-12> 

< 1-13> changing the s ize </H3> 

<HRSIZE= l > 

< HR SIZE=4> 

HRSIZE-IO 

<h3> setting the width</I 13> 

<HR WIDTH =50> < I-IR WIDTI-I=200> 

<. HTML> 
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CONCLUSION 
------_._._-----_._----

ACHIEVEMENTS 

• The project was to develop a comprehensive web site giving complete 

information about Multan, Which I have successfully achieved. 

• There were no sites before which can give us information about Multan 

in deta il. This web s ite provides all the information comprehensively 

about Multan. 

• One aspect that is very important in web sites is the human computer 

interaction. I have tried to ease out all the stuff related to the user and try 

to provide a QUI which user feels comfortable with and enjoy the site. 

• The site covered all the important aspects relating to Multan. It is tried 

that all the important topics should be included. 

FUTURE ENHANCEMENT 

• The site, at present is specific to Multan, but it can be enhanced to be a 
general web site containing information about different cities. 

• A form should be included in the web site to get suggestions from the 
people so that si te can be enhanced as suggested by them. 
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Site Map 

.-------. Fo lk Dances --~--.. Punjab 

Sind 

Main Page Nat ional Anthem Balochistan 

1---.... NWFP 

Kashmir 

~--~-------.--------------- Home 

Site Page of Multan ----

~ 

~ 

~ 

City 

History 

Fort 

City Map 

Shrines 

Mosques 

Parks 

Handicrafts 

Agriculture 

Trave l Services 

Education 

Buildings 

Food & F esti vals 

Picture Gallery 

Misc.Services 
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USER GUIDE 

The main page when open will show following window. A menu will be seen on the 

left side of the main window. Sinc.e the 

Site is relating to 

Multan, only one button 

is alive. i.e 

Main Page 

~ . .J -':l :i\ .sx ~ ..j -j. .J ~ 
ForWbid 51(;ft RoII.th Home Sealch Fa .... OI'lel HidOfY MM Pmt Edt 

_ f'J x -
Multan. l\sldle"ltJ c IW1NOOWS\O"~'oplNew Fok .. IMUL2hlm il ~uo Lrt. » 

~ Dono 

Main Page of the site 
II ~ ,11"'1 nl Mulr.'In MI~.o'nU Intr.ln~ ' rwplnrt'. '.. I .. . 

I /JO ~.. l60w r...... 1'" ~ 
I -.;-: --:;-~-- ~--(1\-'I(t\ . jJ I~ I ~' {fj ~ 
i Bod< [.".", S~ Roll .... ft..o S.- F_....., .... "'" Eell 

~ljl1 [,1\NI'WOws\O;""op\N"" FnIde<\MU' 2 lim 

WELCOME TO MULTAN 
The City Of Saints And Shrines ..... ----
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~~ 

Multan is famous for va rious type s 

of souve ni r s ,Multani Khus sa(5hoes), 

embroidry work of all t ypes , t hread 

and' Aar ' work costwnes fo r ladies , 

embroide re d cloths cholas or kurtas 

'for men' painted and glazed earthe n 

pottery . Camel skin pr oducts, carpets 

Painted Plate 

1- Click for folk dances of Pakistan, 
2- Click Menu for the site ofMultan, 
3- Click for national anthem. 
4- Menu for the tour of the site ofMultan. 
5- Heading for the displayed page. 

• Blue Mullani Tile 

6- Forward and Reverse Buttons.(Do not use browser's reverse and forward buttons). 
7- Main window displaying various information, 
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CHAPTER: 10 

TOUR OF THE SITE 



WELCOME TO MULTAN 
The City Of Saints And Shrines 

------
:\lultan \,a~ e{)ntJu~r~d h~' .\rahs unller 'loh'''lIl11all 

:t'.dIf1_~'lIl1in C)asilll ill 712 A,D, afler Ikfl'alill): Itajll Dahir. a 
dcse~ndalll of {'haeh.Thcreafter, the Tn,," II remained 
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I'akplltlan :11111 lIehli. In IS2!! , callie thc pe,":ful 

1t.~~'/.fI,"J Irall~fer of Ih,' prm illl'(' ttf 1\1 II lIall Ihl' I'lIIis~aril's 
of the .\lII):hal Elllpernr lIahar, l'nder Ihe \lu):hal 
E mp~mrs. I\ lnllllll elljll\ cd a IUIII! periud uf peace 

hehICcll 15 2 11·17~1l '"111 '''IS kll"" II '" Ilar-nl- .. \"' .. 11 

(cit~· ul'llcacc) , 
III 175 11\11111,," hecllme a pru"im:c tmill): 

al\cJ,!ianu lu .\fghull klll):S, II \\a~ Ihell rull'll h~' 

" ;"""U {;,,<\j ·.· ... U·, : .. ,,1 1) :11111 Plltnt ("hil'f\. 



were six gates of the walled city. The 
given to them were historical and 

A straight rond led to dehli from this gate 
for this reason it was called Dehli Gate. 

From this gate women belong to the family of Hazrat Mousa 
Shaheed used to enter the city. For this 

reason it was called Haram Gate. 

From here a straight road led to 
Lahore that Is why it is known as 

IUUI--ar Lahorl Gate which ultimately changed 
to Loharl Gate. 

This qate was qiven name after the name of Pir Ooulat Shah 

_I 
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This garden is locall'll in cantlun Ihc Shn Shah road, The gilrdclI has heauliful 

Ilmrtr hl'!lS and gnl\ s ~' lawns, It i~ IIIHll'r thl' cUlltl'lJ1 of Canlonlllent Board, 
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Chaman Zar-e-Askari Pa ri\: 

This park i,\ alsll IIlCall'lI ill callll 011 SlIl'l' 

Shah mad ncar FilI'I ClllulI~. There is all 

artitidal lalH' ill Ihe park, ,\1oWr hOllt~ ,111(1 

pallllie huul.\ arc IJI'U\' ith~ Il for Ih l' 

cnll'rlaiIlIlH:1I1 Ill' 1Il'1l1'IL:. II h ;l ~ grl'al 
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Ihne Qasim Parl{ 

This park is luetled illfJ'OlI1 uf Ilazral HahaUlldin Zakarill's shrine. The 
R!o.:JIliilii~parl\ has hraillifllilandsl'up, It has II a 1 r 1'1'011 I. artilki:II \\alcrf:llIs, s\\illgs 
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Wbul Is Ih~ mlljflt crop of !\Iultltn. Thlw helps In 
fuifillln!: counlry', fflod dl.'fllIDd , A IlIfgl" an"a Is 
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"t ...... , ............. r ·I ...... " ...... " "" ...... II,.t."".1 ',' .. irl ~I""".", I-to&,..1 
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,'ttlls; bU!ldlng Is located In Cantt at the end of 
Baha.walp~r 'Road. Ifis 'a model of 

construction. PIApooklng office, 
~uilding of Daily Nawa~e-Waqat and other 
banks are 'aiso a beautiful addition to Multan. 

S,tate! ~~~nk Bui lding 
", . ., ~"";,1f":;;7';" 

In 'chowk: Mauj Dirya' , beside the diVision~~!'.'< 
sports grou!1d i ~ sltuated 'asplendld bUlldln'g. ' 

, This building belongs to State Bank. It has s.. ' 
floors. At the ground floor Is a vast banking hall 
Outside ' the ";arandlls Is a sloppy wall wh 

_-.-.' has big archlevlous 'd()ors. The bIJildlng 
decorated with glass ,and blue glazed 
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Hahauddin Zakaria Uni\'crsi 

I'his lIlIh'usih callie illin e~is lallce nil 15 
S~(ll. 1975. In Ih~ IIl·ginni,,!!. il lIas nallled 
us rllil' CI' ~il~ nf \lullan. In 1'171) il I\"~ 
renal1l~d as lIahautidin Zakarill l ' ni\'~rsil\' 

.'Iuli an ,Iflcr th~ '1iI1Il~ or Ihe f:"II\Ju ~ s"ill l 
1I"1 .. al Uah;luddin Zakaria . II h HI"I\I away 

from the cil~· . II has varinlls Ikpartrlll'nis of 

shtar Medical College 
COlll,!!C \\ a~ cntlstructed Oil 10 .Iuly. I 'J51. 

,.~ •• ~sil!nilinltll· l· ill .\sia. It hu~ l'slahlishl'd ilwlf in 
"'1~ .. ,.. •• lhe lielll or kIt,,,, h:llgc . rescarch . puhlical inn 

antlllcallh. This Wlll'!!C has produn'd !!rCal 
dOl'ln!'s . Thl' ~l' n' il'l'~ of l'~J1l'rli~l' allli dUl'lors 
nf 'ishtar 'Icdiral Cnlle!!c art' l'('('II\!niwd 

1Ir~1I::~lhroul!huUI Ihe 'rurlt!. 
~I 
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{ ' i\'illlo~pital • ,," at ima .Jinnah Womcn Hllspital 

("1\111 '11I11all . Christian IImpital 

Police Stations 

Post ()r1iccs 
Ccnc!"al I'mt Ollin: 
lIa~~all I'an\ alia Ho atl 

TOll rist Sc .-vices 

• "olin' S I'l lion .Ialilahatl 

. I'olil'c Stat iml (;lIlghshat 

( 'alill I'osl (Hlkc 
,\Iall I{oad 

• Ilaram Catc 
Ca llll Bal.ar 

,I 

I 
I 
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